27
2018
08

Centos 7.x 安装 Swoole 4.0.x

  1. 安装依赖包

    openssl, openssl-devel, 

  2. 安装编译程序

    gcc, gcc-c++

  3. 安装http2依赖 nghttp2

    https://github.com/nghttp2/nghttp2/releases

    下载后解压缩并编译 

  4. tar zxvf nghttp2-1.32.1.tar.gz
    cd nghttp2-1.32.1
    ./configure
    make
    make install
  5. 安装swoole

    pecl install swoole

    根据提示操作即可

    备注:php-mysql依赖包请使用mysqlnt包

« 上一篇